BLE connectivity Issue | Cypress Semiconductor

BLE connectivity Issue

Summary:1 Reply, Latest post by Anjana Muralidharan on 28 Mar 2017 11:22 PM PDT
Verified Answers:1
Last post
Log in to post new comments.
jkgupta654_2265946's picture
User
4 posts

Hi Everyone,

When I'm trying to connect my device with Cysmart either in android or IOS, I'm getting disconnected frequently.

In android getting the msg Bluetooth Disconnected, whereas in IOS I'm getting "Connection Timed out unexpectedly".

How to achieve consistency in connectivity and what are the parameters which are affecting the connectivity.

Regards, 

Jatin

Anjana Muralidharan's picture
Cypress Employee
158 posts

Hi Jatin,

Probably your peripheral project have some issue.If possible, please share your project and steps to reproduce to test at our side.

Please let us know the below:

- Whether the peripheral is advertising again after the disconnection?

- Are you using our BLE pioneer kit or custom board?

- Did you check the Disconnect reason at peripheral side ?Are you getting disconnect event ?

 How to check:

Event CYBLE_EVT_GAP_DEVICE_DISCONNECTED :Disconnected from remote device or failed to establish connection.Parameter returned with the event contains pointer to the reason for disconnection, which is of type uint8.For details refer core spec 4.2, vol2, part D .

So what you have to do in the project is hope there will be a UART to see the debug prints in the project.If then, in the CYBLE_EVT_GAP_DEVICE_DISCONNECTED event, print the event parameter value, for eg:

printf("Error code is :0x%x",*(uint8 *)eventParam);

and see what error code are you getting.Now check in the core spec part mentioned, there you can find the reason of error code.This is the way to find the reason.

 

Thanks & Regards,

Anjana

 

Log in to post new comments.